use strict;
my $str = '[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]';
my $regex = qr/\[\s[A-Z]=(?<New_Field>[^\][]*)\s]/mp;
my $subst = '$11.0.0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";