import Foundation
let pattern = #"\[\s[A-Z]=(?<New_Field>[^\][]*)\s]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$11.0.0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)