// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\s[A-Z]=(?<New_Field>[^\][]*)\s]").unwrap();
let string = "[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]";
let substitution = "$11.0.0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}