using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s[A-Z]=(?<New_Field>[^\][]*)\s]";
string substitution = @"$11.0.0";
string input = @"[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}