#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\s[A-Z]=(?<New_Field>[^\][]*)\s]"
Local $sString = "[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]"
Local $sSubst = "$11.0.0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)