# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?(DEFINE)
(?<first>[\pL\d'’])
(?<other>[-\ \pL\d.'\/,’])
)
\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|./x/iuxg;t' <<< "-
Random-morestuff
Random%morestuff
Rândôm
"