$re = '#(?(DEFINE)
(?<first>[\pL\d\'’])
(?<other>[-\ \pL\d.\'/,’])
)
\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|.#iux';
$str = '-
Random-morestuff
Random%morestuff
Rândôm
';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;