package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ix)(?(DEFINE)
(?<first>[\pL\d'’])
(?<other>[-\ \pL\d.'/,’])
)
\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|.`)
var str = `-
Random-morestuff
Random%morestuff
Rândôm
`
var substitution = "x"
fmt.Println(re.ReplaceAllString(str, substitution))
}