import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<first>[\\pL\\d'’])\n"
+ " (?<other>[-\\ \\pL\\d.'/,’])\n"
+ ")\n"
+ "\\b(?&first)(?&other)+\\b(*SKIP)(*FAIL)|.";
final String string = "-\n"
+ "Random-morestuff\n"
+ "Random%morestuff\n"
+ "Rândôm\n";
final String subst = "x";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}