// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iux)(?(DEFINE)
(?<first>[\pL\d'’])
(?<other>[-\ \pL\d.'/,’])
)
\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|.").unwrap();
let string = "-
Random-morestuff
Random%morestuff
Rândôm
";
let substitution = "x";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}