#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?iux)(?(DEFINE)" & @CRLF & _
" (?<first>[\pL\d'’])" & @CRLF & _
" (?<other>[-\ \pL\d.'/,’])" & @CRLF & _
")" & @CRLF & _
"\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|."
Local $sString = "-" & @CRLF & _
"Random-morestuff" & @CRLF & _
"Random%morestuff" & @CRLF & _
"Rândôm" & @CRLF & _
""
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)