use strict;
my $str = '-
Random-morestuff
Random%morestuff
Rândôm
';
my $regex = qr#(?(DEFINE)
(?<first>[\pL\d'’])
(?<other>[-\ \pL\d.'/,’])
)
\b(?&first)(?&other)+\b(*SKIP)(*FAIL)|.#iuxp;
my $subst = 'x';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";