const regex = new RegExp('(?(DEFINE)
(?<first>[\\pL\\d\\'’])
(?<other>[-\\ \\pL\\d.\\'/,’])
)
\\b(?&first)(?&other)+\\b(*SKIP)(*FAIL)|.', 'iug')
const str = `-
Random-morestuff
Random%morestuff
Rândôm
`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);