#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?"
Local $sString = " <a href="www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf" title="xxx na facebooku" target="_blank"><i class="fab fa-facebook-square fa-lg" aria-hidden="true"></i>xxx</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")