import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/\\/\\/.*)?facebook\\.com(?:\\/[^ \"]*)?";
final String string = " <a href=\"www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf\" title=\"xxx na facebooku\" target=\"_blank\"><i class=\"fab fa-facebook-square fa-lg\" aria-hidden=\"true\"></i>xxx</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}