$re = '/(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?/m';
$str = ' <a href="www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf" title="xxx na facebooku" target="_blank"><i class="fab fa-facebook-square fa-lg" aria-hidden="true"></i>xxx</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);