const regex = /(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/\\\/\\\/.*)?facebook\\.com(?:\\\/[^ "]*)?', 'gm')
const str = ` <a href="www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf" title="xxx na facebooku" target="_blank"><i class="fab fa-facebook-square fa-lg" aria-hidden="true"></i>xxx</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}