re = /(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?/m
str = ' <a href="www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf" title="xxx na facebooku" target="_blank"><i class="fab fa-facebook-square fa-lg" aria-hidden="true"></i>xxx</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end