// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?"#).unwrap();
let string = " <a href=\"www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf\" title=\"xxx na facebooku\" target=\"_blank\"><i class=\"fab fa-facebook-square fa-lg\" aria-hidden=\"true\"></i>xxx</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}