package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/\/\/.*)?facebook\.com(?:\/[^ "]*)?`)
var str = ` <a href="www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf" title="xxx na facebooku" target="_blank"><i class="fab fa-facebook-square fa-lg" aria-hidden="true"></i>xxx</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}