using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\[[^][]*)\s+(?=[^][]*])";
string substitution = @"_";
string input = @"[ a b c ] d e f
[Skip a Payment] [decimal](18,2)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}