re = /(?<=\[[^][]*)\s+(?=[^][]*])/m
str = '[ a b c ] d e f
[Skip a Payment] [decimal](18,2)'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result