$re = '/(?<=\[[^][]*)\s+(?=[^][]*])/m';
$str = '[ a b c ] d e f
[Skip a Payment] [decimal](18,2)';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;