const regex = new RegExp('(?<=\\[[^][]*)\\s+(?=[^][]*])', 'gm')
const str = `[ a b c ] d e f
[Skip a Payment] [decimal](18,2)`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);