use strict;
my $str = '[ a b c ] d e f
[Skip a Payment] [decimal](18,2)';
my $regex = qr/(?<=\[[^][]*)\s+(?=[^][]*])/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";