# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^.]+)\..*|^(.{10}).*/\1\2/gm;t' <<< "Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est"