package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.]+)\..*|^(.{10}).*`)
var str = `Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}