const regex = /^([^.]+)\..*|^(.{10}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^.]+)\\..*|^(.{10}).*', 'gm')
const str = `Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);