re = /^([^.]+)\..*|^(.{10}).*/m
str = 'Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result