using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^.]+)\..*|^(.{10}).*";
string substitution = @"\1\2";
string input = @"Lorem ipsum dolor sit amet. consectetur
Donec quis turpis sed sapien ullamcorper viverra sodales a est";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}