#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)"
Local $sString = "1.0" & @CRLF & _
"0.0" & @CRLF & _
"0.1" & @CRLF & _
"0.2" & @CRLF & _
"0.9" & @CRLF & _
"0.19" & @CRLF & _
"1.1" & @CRLF & _
"3.0" & @CRLF & _
"4.0" & @CRLF & _
"5.0" & @CRLF & _
"5.00" & @CRLF & _
"5.1" & @CRLF & _
"4.11" & @CRLF & _
"5.22" & @CRLF & _
"0" & @CRLF & _
"4.99" & @CRLF & _
"5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")