use strict;
my $str = '1.0
0.0
0.1
0.2
0.9
0.19
1.1
3.0
4.0
5.0
5.00
5.1
4.11
5.22
0
4.99
5';
my $regex = qr/^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}