package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)`)
var str = `1.0
0.0
0.1
0.2
0.9
0.19
1.1
3.0
4.0
5.0
5.00
5.1
4.11
5.22
0
4.99
5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}