re = /^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)/m
str = '1.0
0.0
0.1
0.2
0.9
0.19
1.1
3.0
4.0
5.0
5.00
5.1
4.11
5.22
0
4.99
5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end