import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(5$|5.0$|5.00$|^(?:4(?:\\.[0-9]{0,2})?|[1-4](?:\\.[0-9]{0,2})?|1?\\.[0-9]{0,2})$)";
final String string = "1.0\n"
+ "0.0\n"
+ "0.1\n"
+ "0.2\n"
+ "0.9\n"
+ "0.19\n"
+ "1.1\n"
+ "3.0\n"
+ "4.0\n"
+ "5.0\n"
+ "5.00\n"
+ "5.1\n"
+ "4.11\n"
+ "5.22\n"
+ "0\n"
+ "4.99\n"
+ "5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}