using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)";
string input = @"1.0
0.0
0.1
0.2
0.9
0.19
1.1
3.0
4.0
5.0
5.00
5.1
4.11
5.22
0
4.99
5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}