import re
regex = re.compile(r"^(5$|5.0$|5.00$|^(?:4(?:\.[0-9]{0,2})?|[1-4](?:\.[0-9]{0,2})?|1?\.[0-9]{0,2})$)", flags=re.MULTILINE)
test_str = ("1.0\n"
"0.0\n"
"0.1\n"
"0.2\n"
"0.9\n"
"0.19\n"
"1.1\n"
"3.0\n"
"4.0\n"
"5.0\n"
"5.00\n"
"5.1\n"
"4.11\n"
"5.22\n"
"0\n"
"4.99\n"
"5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")