#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$"
Local $sString = "[bracketed text]" & @CRLF & _
"[more_bracketed_text]" & @CRLF & _
"" & @CRLF & _
"not fully [bracketed]" & @CRLF & _
"[has a ] close bracket in middle]" & @CRLF & _
"[space after] " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")