$re = '/^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$/m';
$str = '[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);