re = /^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$/m
str = '[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end