// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$").unwrap();
let string = "[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}