package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$`)
var str = `[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}