using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(([^ \[\]\t\r\n]+)( *([^ \[\]\t\r\n]+))*)\]$";
string input = @"[bracketed text]
[more_bracketed_text]
not fully [bracketed]
[has a ] close bracket in middle]
[space after]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}