using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\/";
string input = @"<td class=""text-right""
onmouseenter=""$(this).find('.overlay-viewable-box:first').show();""
onmouseleave=""$(this).find('.overlay-viewable-box:first').hide();"">
2.004
</td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}