import re
regex = re.compile(r">[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\/")
test_str = ("<td class=\"text-right\"\n"
" onmouseenter=\"$(this).find('.overlay-viewable-box:first').show();\"\n"
" onmouseleave=\"$(this).find('.overlay-viewable-box:first').hide();\">\n\n\n\n\n"
" 2.004\n\n\n\n\n\n"
" </td>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")