const regex = />[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>[\\s]*([[:digit:]]+(\\.[[:digit:]]+)?)[\\s]*<\\\/', 'g')
const str = `<td class="text-right"
onmouseenter="\$(this).find('.overlay-viewable-box:first').show();"
onmouseleave="\$(this).find('.overlay-viewable-box:first').hide();">
2.004
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}