// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r">[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\/").unwrap();
let string = "<td class=\"text-right\"
onmouseenter=\"$(this).find('.overlay-viewable-box:first').show();\"
onmouseleave=\"$(this).find('.overlay-viewable-box:first').hide();\">
2.004
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}