$re = '/>[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\//';
$str = '<td class="text-right"
onmouseenter="$(this).find(\'.overlay-viewable-box:first\').show();"
onmouseleave="$(this).find(\'.overlay-viewable-box:first\').hide();">
2.004
</td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);