import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">[\\s]*([[:digit:]]+(\\.[[:digit:]]+)?)[\\s]*<\\/";
final String string = "<td class=\"text-right\"\n"
+ " onmouseenter=\"$(this).find('.overlay-viewable-box:first').show();\"\n"
+ " onmouseleave=\"$(this).find('.overlay-viewable-box:first').hide();\">\n\n\n\n\n"
+ " 2.004\n\n\n\n\n\n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}