package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`>[\s]*([[:digit:]]+(\.[[:digit:]]+)?)[\s]*<\/`)
var str = `<td class="text-right"
onmouseenter="$(this).find('.overlay-viewable-box:first').show();"
onmouseleave="$(this).find('.overlay-viewable-box:first').hide();">
2.004
</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}